Install the Go API client

Install

Download the Go client using:

go get github.com/algolia/algoliasearch-client-go/algoliasearch

Supported platforms

This API client is compatible with Go 1.7 and above.

Language-specific notes

Migration note from v1.x to v2.x

In June 2016, we released the v2 of our Go client. If you were using version 1.x of the client, read the migration guide to version 2.x. Version 1.x are no longer under active development. They are still supported for bug fixes, but will not receive new features.